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USER’S GUIDE
Preface
INTRODUCTION
This chapter contains general information that will be useful to know before using the 
PIC18F4XK20 Starter Kit. Items discussed in this chapter include:
• Document Layout
• Conventions Used in this Guide
• Recommended Reading
• The Microchip Web Site
• Development Systems Customer Change Notification Service
• Customer Support
• Document Revision History

DOCUMENT LAYOUT
This document describes how to use the PIC18F4XK20 Starter Kit as a development 
tool to emulate and debug firmware on a target board. The manual layout is as follows: 
• Chapter 1. PIC18F4XK20 Starter Kit Overview  – Introduces the PIC18F4XK20 

Starter Kit and provides a brief description of the hardware and the new features.
• Chapter 2. Troubleshooting  – Describes the common problems of the 

PIC18F4XK20 Demonstration Board and their solutions.
• Appendix A. Board Schematics  – Provides schematic diagrams for the 

PIC18F4XK20 Demonstration Board.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 
document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. 
Select the Help menu, and then Topics to open a list of available on-line help files.
© 2008 Microchip Technology Inc. DS41344B-page 1
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CONVENTIONS USED IN THIS GUIDE
This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS
Description Represents Examples

Arial font:
Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...
Initial caps A window the Output window

A dialog the Settings dialog
A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

“Save project before build”

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK
A tab Click the Power tab

N‘Rnnnn A number in verilog format, 
where N is the total number of 
digits, R is the radix and n is a 
digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>
Courier New font:
Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 
any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}

DS41344B-page 2 © 2008 Microchip Technology Inc.



Preface
RECOMMENDED READING
This user's guide describes how to use the PIC18F4XK20 Starter Kit. Other useful doc-
uments are listed below. The following Microchip documents are available and recom-
mended as supplemental reference resources.
PIC18F46K20 Data Sheet (DS41303)
This data sheet summarizes the features of the PIC18F46K20. It provides essential 
information needed to develop software for this device.
MCP9700/9700A and MCP9701/9701A Data Sheet (DS21942)
This data sheet summarizes the features of the MCP9700/9700A and 
MCP9701/9701A. It provides essential information needed to develop software for 
these devices.
MCP001/2/4 Data Sheet (DS21733)
This data sheet summarizes the features of the MCP001/2/4. It provides essential 
information needed to develop software for these devices.
25LC1024 Data Sheet (DS22064)
This data sheet summarizes the features of the 25LC1024. It provides essential 
information needed to develop software for this device.

THE MICROCHIP WEB SITE
Microchip provides online support via our web site at www.microchip.com. This web 
site is used as a means to make files and information easily available to customers. 
Accessible by using your favorite Internet browser, the web site contains the following 
information:
• Product Support – Data sheets and errata, application notes and sample 

programs, design resources, user’s guides and hardware support documents, 
latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives
© 2008 Microchip Technology Inc. DS41344B-page 3
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DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE
Microchip’s customer notification service helps keep customers current on Microchip 
products. Subscribers will receive e-mail notification whenever there are changes, 
updates, revisions or errata related to a specified product family or development tool of 
interest.
To register, access the Microchip web site at www.microchip.com, click on Customer 
Change Notification and follow the registration instructions.
The Development Systems product group categories are:
• Compilers – The latest information on Microchip C compilers and other language 

tools. These include the MPLAB C18 and MPLAB C30 C compilers; MPASM™ 
and MPLAB ASM30 assemblers; MPLINK™ and MPLAB LINK30 object linkers; 
and MPLIB™ and MPLAB LIB30 object librarians.

• Emulators – The latest information on Microchip in-circuit emulators.This 
includes the MPLAB ICE 2000 and MPLAB ICE 4000.

• In-Circuit Debuggers – The latest information on the Microchip in-circuit 
debugger, MPLAB ICD 2.

• MPLAB® IDE – The latest information on Microchip MPLAB IDE, the Windows® 
Integrated Development Environment for development systems tools. This list is 
focused on the MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager 
and general editing and debugging features.

• Programmers – The latest information on Microchip programmers. These include 
the MPLAB PM3 and PRO MATE® II device programmers and the PICSTART® 
Plus and PICkit™ 1 development programmers.

CUSTOMER SUPPORT
Users of Microchip products can receive assistance through several channels:
• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support
Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document.
Technical support is available through the web site at: http://support.microchip.com

DOCUMENT REVISION HISTORY

Revision A (March 2008)
• Initial Release of this Document.

Revision B (April 2008)
• Removed reference to OLED Data Sheet
DS41344B-page 4 © 2008 Microchip Technology Inc.
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USER’S GUIDE
Chapter 1.  PIC18F4XK20 Starter Kit Overview
The PIC18F4XK20 Starter Kit is a demonstration and development tool designed for 
those getting started with microcontrollers or those looking to migrate to the new 
PIC18F4XK20/2XK20 family. The board is designed for general purpose applications 
and includes a variety of hardware to exercise microcontroller peripherals. 

1.1 OVERVIEW
The PIC18F4XK20/2XK20 is a new family of microcontrollers that take advantage of 
Microchip’s latest process technology. Among the most notable of the new features are:
• lower power consumption
• high-performance operation and
• low-cost
Several firmware demos that showcase some of the features are included, as well as 
a PICkit™ 2 Development Programmer, which can be used to download the demos 
onto the development board.
The hardware included on the board allows for development as well. The microcontroller 
that is populated on the board, the PIC18F46K20, is the superset of the PIC18F4XK20/2XK20 
family. Included on the board are various analog and digital circuitry used in 
microcontroller applications, in addition to a header which breaks out all signal lines for 
analysis or interfacing to external devices. 

1.2 HIGHLIGHTS
This chapter discusses the features of the PIC18F4XK20 Starter Kit. Topics discussed 
include:
• PIC18F4XK20 Starter Kit Contents
• PIC18F4XK20 System Management Layout
• Powering the Demo Board
• Quick Start Guide
• Programming Lessons

1.3 PIC18F4XK20 STARTER KIT CONTENTS
The PIC18F4XK20 Starter Kit includes the following items:
• PIC18F4XK20 Starter Kit Board
• PIC18F4XK20 CD-ROM, which includes:

- PIC18F4XK20 Starter Kit User’s Guide
- PIC18F4XK20 Schematics and Layout
- Labs and Demo Software Source Code
- PIC18F4XK20/2XK20 Data Sheets
- 25LC1024 Data Sheet

• PICkit 2 Development Programmer
• Programming Lessons
© 2008 Microchip Technology Inc. DS41344B-page 5
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If you are missing any part of the kit, please contact your nearest Microchip sales office 
listed on the back of this publication.

1.4 PIC18F4XK20 STARTER KIT LAYOUT
The PIC18F4XK20 Starter Kit Board is populated with a PIC18F46K20 microcontroller. 
In addition, the board is also populated with the following features/components:
• 128x64 Organic LED Display (SPI)
• 32.768 kHz External Oscillator (Timer1)
• Analog Input Filtering and Gain Control into RE1 (1.4.1)
• PWM Output Filtering from RC2 (1.4.2)
• 4 Push Buttons for User Interfacing
• 1 MCLR switch
• 8 LEDs mapped to PORTD
• Potentiometer 
• 1024 KB Serial EEPROM 
• PICtail™ daughter board header (breaks out all pins)
• 6-Pin ICSP™ programming capability header
• 6-Pin PICkit serial analyzer interface 
• Current measurement jumper
• RJ-11 ICSP programming header

FIGURE 1-1: STARTER KIT LAYOUT

MCP9700

Audio/Analog
OUT

Audio/Analog IN with
Adjustable Gain

PICkitTM Serial

PICtailTM Header

Serial EEPROM O-LED 
Display

ICD2 Interface Interface+5-12V Power

Pushbuttons and POT
Temperature
Sensor

32 kHz xTAL

PICkitTM 2 Interface
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1.4.1 Analog Input Filtering Circuit 
The analog filtering circuit is designed for use with an electret microphone. Electret 
microphones typically require biasing, which is provided by MIC bias jumper, JP3. The 
analog signal generated by a typical electret microphone has a peak to peak voltage in 
the single millivolts range. The analog filtering circuit has a maximum gain of 300 which 
can be controlled with the potentiometer labeled GAIN and is a 2nd order low-pass filter 
with a cut-off frequency of 5 kHz. Jumper JP3 needs to be removed if the analog input 
is provided by input test point.

1.4.2 PWM Filtering from RC2
The microcontroller output RC2 provides an active low pass filter that can be used to 
generate analog signals. A high frequency PWM output from RC2 can be pulse width 
modulated to vary the amplitude of the output signal.

1.4.3 PICtail Daughter Board Interface
The PICtail daughter board interface breaks out each pin of the microcontroller in 
addition to providing +VDD and ground. The header is designed to be compatible with 
existing PICtail daughter boards. Visit the Microchip web site to find more details on 
PICtail daughter boards.

1.4.4 PICkit Serial Analyzer Connector
The PICkit serial analyzer connector provides pins for serial communication. The serial 
communications lines are designed to be used with the PICkit serial analyzer, but are 
also provided for general purpose communications as well. The Serial Communications 
pinout is shown below:

FIGURE 1-2: SERIAL COMMUNICATIONS PIN-OUT

1.4.5 ICSP™ (In-Circuit Serial Programmer™) Connector 
A 6-pin ICSP programming capability and RJ-11 connectors are provided for 
programming the microcontroller. The PIC18F46K20 can be programmed through 
these connectors using the PICkit 2 programmer in the MPLAB ICD 2. 

1 2 3 4 5 6

TX +5V GND SDA SCL RX

Note: The programming voltage on the microcontroller VPP pin must be below 9V 
according to the programming specification. Protection circuitry (8.2V 
Zener with 820 Ohm series resistor) is in place to ensure that VPP does not 
exceed programming specifications.
© 2008 Microchip Technology Inc. DS41344B-page 7
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1.4.6 Temperature Sensor
An MCP9700 temperature sensor is located on the board. The MCP9700 is an analog 
temperature sensor that provides a linear voltage output versus temperature. The 
voltage output of the temperature sensor is connected to the RE1 pin of the microcontroller. 

1.4.7 25LC1024 Serial EEPROM
A Microchip 1024 Kbit serial reprogrammable Flash memory with both Flash and 
byte-level serial EEPROM functions is provided. 
The memory is accessed via a simple Serial Peripheral Interface (SPI) compatible 
serial bus. The bus signals are a clock input plus separate data in and data out lines. 
Access to the device is controlled by a Chip Select (CS) input on the microcontroller pin 
RA6.

1.4.8 32.768 kHz Crystal 
The 32.768 kHz tuning fork crystal is interfaced to the RC0/T1OSO and RC1/T1OSI 
pins for use with the Timer1 peripheral. 

1.4.9 128x64 OLED 
The display provided on the development board is a 128x64 organic LED display. It 
interfaces to the microcontroller via Serial Peripheral Interface (SPI). The controller on 
the OLED is the SH1101A.

1.5 POWERING THE DEMO BOARD
The demonstration board can be powered in the following ways:
1. The board accepts a 2.5mm coaxial power connector in J3.  Acceptable voltages 

range from +5-12 VDC.
2. The PICkit 2 Development programmer can be used to provide power at connec-

tor P1.  Do not exceed current of 100 mA on the board if the PICkit 2 is being 
used to power the board.  

3. The PICkit Serial Analyzer can be used to provide power at connector P2.  Do 
not exceed a current of 100 mA on the board if the PICkit Serial Analyzer is being 
used to power the board.

1.6 QUICK START GUIDE
The PIC18F4XK20 Starter Kit is preloaded with demonstration firmware. The board 
must be configured as described in this section in order to use the demonstration programs.
Board Setup
1. Close jumper JP1 labeled Current Jumper, JP3 labeled Mic Bias and JP2.
2. Connect a +5-12V power supply to connector J3 in the upper left portion of the 

board.

1.6.1 Downloading Demonstration Software
The PIC18F4XK20 Starter Kit CD-ROM comes with 3 demonstration programs and 12 
hands-on programming lessons. Using the PICkit 2 Development Programmer, dem-
onstration firmware can be downloaded onto the demo board and the board can be 
powered.
DS41344B-page 8 © 2008 Microchip Technology Inc.



PIC18F4XK20 Starter Kit Overview
1. Insert the included PIC18F4XK20 Demonstration Board CD into the CD-ROM 
Drive.

2. Run the installation setup for MPLAB IDE.
3. Connect the PICkit 2 programmer to the Starter Kit board and computer.
4. Start the MPLAB IDE software.
5. Click File > Import.

FIGURE 1-3: IMPORT

6. Browse to the CD-ROM drive directory Demos.
7. Select one of the several demos available (readme.txt in the Demos directory 

will describe each demo) and click Open:
© 2008 Microchip Technology Inc. DS41344B-page 9
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FIGURE 1-4: DEMOS AVAILABLE

8. Click Programmer > Select Programmer > PICkit 2:

FIGURE 1-5:

9. To program, click Programmer > Program.
10. Click Programmer > Release from Reset to release the MCLR to run the 

program.

1.7 PROGRAMMING LESSONS
The PIC18F4XK20 CD-ROM includes a variety of programming lessons designed for 
use with the demonstration board. Insert the PIC18F4XK20 CD-ROM and browse to 
the Lessons directory of the CD-ROM.
DS41344B-page 10 © 2008 Microchip Technology Inc.
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Chapter 2.  Troubleshooting
2.1 INTRODUCTION
This chapter describes common problems when using the PIC18F4XK20 
Demonstration Board and their solutions.

2.1.1 The board does not power up.
Make sure that the green POWER LED has turned on. If the LED is not on, check to 
see that the +9V power supply is properly connected.

2.1.2 Microcontroller is not executing code.
First check to make sure that the microcontroller has been programmed with the firm-
ware that is intended to run. If the part is programmed, ensure that the current jumper 
JP1 is in place. 

2.1.3 The microcontroller will not program.
Check to make sure that the programmer/debugger is properly connected to the PC 
and powered. Make sure that the board is also powered with the +9V power supply. 
Programming can only occur when the current jumper JP1 is connected.
© 2008 Microchip Technology Inc. DS41344B-page 11
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Appendix A. Board Schematics
A.1 INTRODUCTION
This appendix contains the PIC18F4XK20 demonstration board schematics, broken 
down into 5 sheets, as follows:

FIGURE A-1: PIC18F4XK20 DEMO BOARD SCHEMATIC DIAGRAM (SHEET 1 OF 5)
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FIGURE A-2: PIC18F4XK20 DEMO BOARD SCHEMATIC DIAGRAM (SHEET 2 OF 5)

MCP9700-I/LT
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Board Schematics
FIGURE A-3: PIC18F4XK20 DEMO BOARD SCHEMATIC DIAGRAM (SHEET 3 OF 5) 
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FIGURE A-4: PIC18F4XK20 DEMO BOARD SCHEMATIC DIAGRAM (SHEET 4 OF 5) 
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Board Schematics
FIGURE A-5: PIC18F4XK20 DEMO BOARD SCHEMATIC DIAGRAM (SHEET 5 OF 5) 
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